Monday, November 5, 2012

[SOLVED] xfrun4/xfce4-appfinder launches very slowly

xfrun4 is a little Xfce program that allows to run commands, without having to open a terminal window. Since Xfce 4.10 it also works as a application launcher.

It is summoned using Alt+F2, and usually it pops right up, but lately it takes several seconds, sometimes almost a minute, to open.

When trying to run it from the terminal, it prints this error:

(xfrun4:6232): xfce4-appfinder-CRITICAL **: Failed to open window: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

This bug has been reported and there's a workaround: use the --disable-server option.

Fix

So to fix this we'll replace the command for the Alt+F2 shortcut with "xfrun4 --disable-server". Open a terminal window and run:

xfconf-query -c xfce4-keyboard-shortcuts -p '/commands/custom/<Alt>F2' -s "xfrun4 --disable-server"

References

Bug #1048805 “xfrun4 launches very slowly”

25 comments:

  1. Seems like the <Alt&gt disappeared from after F2

    ReplyDelete
  2. Thanks! Works like a charm, now!

    But what exactly are we missing without the server stuff?

    ReplyDelete
    Replies
    1. Glad that helped.

      With this option xfrun4 won't become a D-Bus service (inter-process communication between applications). As a user I never missed this functionality.

      Delete
  3. Yup, thanks! Much less frustrating when things work like they used to :)

    ReplyDelete
  4. Thanks for this. I noticed this problem appears for me after I replaced xfwm with the gala window manager, with this workaround it works normally again!

    ReplyDelete
  5. It worked :-)

    Thanks.

    ReplyDelete
  6. Thanks a lot for this!

    ReplyDelete
  7. After over 1 year it's still solution, thanks!

    ReplyDelete
  8. Fantastic!

    Tanks so much.

    ReplyDelete
  9. thanks ,you are my new hero! +10 karma points your way

    ReplyDelete
  10. Following,

    xfconf-query -c xfce4-keyboard-shortcuts -p '/commands/custom/F3' -s "xfce4-appfinder --disable-server"

    ReplyDelete
  11. Killing the deamonized thread (killall -9 xfrun4) solved the problem for me.

    ReplyDelete
  12. Thanks, it woked for me, 15.05.2015

    ReplyDelete
  13. It's amazing that we are almost in 2016 and this is still an issue.
    Thanks for the post, it works, although if you manually click on the menu it obviously still takes ages.

    ReplyDelete
  14. Awesome! (Yes, still an issue)

    ReplyDelete